how to add some tags to lzx files for code completion

Get help with Spket IDE.
cemsonmez
Posts: 12
Joined: Tue Jun 09, 2009 2:42 pm

how to add some tags to lzx files for code completion

Post by cemsonmez » Tue Jun 09, 2009 2:59 pm

Hi, i m working on OpenLaszlo. the lps version is 4.2 and i m using spket for writing lzx files. First thanks for this nice editor.
My question is about :

In a lzx file, some of the tags in $lps-server-home/lps/components/ isn't available for code completion suggestion in spket. For example: while there is <method> tag is available for code completion, <button> tag isnT. I can only see the button tag, at the right side of the editor in snippets. İs it possible to add the related path to spket editor and use all the components for the code completion ? How can i do that, if it is possible.

Regards.[/u]

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Tue Jun 09, 2009 6:29 pm

choose menu item Window -> Preferences..., in dialog, choose item Spket -> Laszlo, setup the directory for Laszlo, click OK to save the setting.

cemsonmez
Posts: 12
Joined: Tue Jun 09, 2009 2:42 pm

Post by cemsonmez » Tue Jun 09, 2009 7:50 pm

I have done this, but still some of the tags arenT available for code compeletion.

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Wed Jun 10, 2009 2:48 am

could you tell me which tags are not avaiable for code compeletion?

cemsonmez
Posts: 12
Joined: Tue Jun 09, 2009 2:42 pm

Post by cemsonmez » Wed Jun 10, 2009 11:02 am

all the tags which are in the "snippets" area and another some tags. For example : button, tabslider, radiobutton, rtmpconnection ...

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Wed Jun 10, 2009 1:08 pm

I have tried Laszlo 4.2 and Laszlo 4.3, both work fine, do you have any other laszlo editor plugins installed? are you use Spket standalone version or install it as a plugin?

cemsonmez
Posts: 12
Joined: Tue Jun 09, 2009 2:42 pm

Post by cemsonmez » Wed Jun 10, 2009 1:19 pm

i m using Laslo 4.2 and spket standalone version. I m not sure uninstalling spket, using the latest version or installing it as a plugin will solve the problem. I will try try them and post back the results to here. Thanks for your replies Eric.

cemsonmez
Posts: 12
Joined: Tue Jun 09, 2009 2:42 pm

Post by cemsonmez » Wed Jun 10, 2009 7:32 pm

- I have removed spket directory which was installed to the system before.
- Downloaded the standalone version again and installed it.

The related problem goes on. Some of the tags are not available for code completion although i have specified Window -> Preferences->Spket -> Laszlo directory with ("/opt/lps-4.2.0.2/Server/lps-4.2.0.2/" which is my lps directory). I can use these tags only via snippets area. And the tags are in snippets area have not their own attributes completely. So i have to look at the openlaszlo reference to learn about the attributes of the tags.

- I have also added spket latest plugin to Eclipse Ganymede release. The problem is same for the spket as eclipse plugin.

PS : While creating my Spket projects, i m creating a "general project" and then a file named "blabla.lzx" for that project. Thıs is true, isnT it ? Bec. there is no option like to create laszlo project or lzx file.

I m waiting for your replies.
Regards.

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Thu Jun 11, 2009 2:49 am

Seems you are using Linux, what is your java version? and is there any error in file workspace/.metadata/.log

cemsonmez
Posts: 12
Joined: Tue Jun 09, 2009 2:42 pm

Post by cemsonmez » Thu Jun 11, 2009 7:44 pm

Yes, i m using Linux.
- Java version : 1.6.0_13
- there is no .log file under my spket workspace. The result of "ls -a" under my spket workspace directory :

.lock
.plugins
version.ini

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Fri Jun 12, 2009 8:57 am

It is a bug on Linux, I have upload a quick fix, please download http://www.agpad.com/downloads/com.spket.ui_1.6.16.jar and replace the old one.

cemsonmez
Posts: 12
Joined: Tue Jun 09, 2009 2:42 pm

Post by cemsonmez » Fri Jun 12, 2009 11:46 am

Ok Eric, now it's working fine for me. Thanks very much for that quick replies and solution.
This fix became great for me.

cemsonmez
Posts: 12
Joined: Tue Jun 09, 2009 2:42 pm

Post by cemsonmez » Thu Oct 22, 2009 12:10 pm

hi again
with new spket version, the problem goes on. the name of the related file is "com.spket.ui_1.6.18.jar". As i said before i m using linux and canT use some tags in laszlo.
Or should i go on using the older spket (which has com.spket.ui_1.6.18.jar).
Thanks.

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Thu Oct 22, 2009 2:46 pm

I have test in Linux, and everything seems fine, have you setup the Laszlo path in preferences? is your Spket a fresh installation or update from old version?

cemsonmez
Posts: 12
Joined: Tue Jun 09, 2009 2:42 pm

Post by cemsonmez » Thu Oct 22, 2009 8:25 pm

Oh, i m so sorry. I had forgotten to setup the path of Laszlo at the preferences window. Now it works fine for me too. Thanks a lot.
Regards.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests