eclipse 3.4.2 with qooxdoo 8.3-svn: NullPointerException

Get help with Spket IDE.
Post Reply
marcel
Posts: 2
Joined: Mon Jun 22, 2009 7:05 am

eclipse 3.4.2 with qooxdoo 8.3-svn: NullPointerException

Post by marcel » Mon Jun 22, 2009 7:12 am

Hi,

I have downloaded 1.6.16 from update site
into my eclipse 3.4.2 on Linux.
And configured for qooxdoo as described under qooxdoo.html

When opening a .js file I get a NullPointerException:

!ENTRY org.eclipse.core.jobs 4 2 2009-06-22 08:57:36.973
!MESSAGE An internal error occurred during: "Loading Context".
!STACK 0
java.lang.NullPointerException
at com.spket.as.internal.compiler.problem.ProblemHandler.handle(Unknown Source)
at com.spket.as.internal.compiler.problem.ProblemHandler.handle(Unknown Source)
at com.spket.as.internal.compiler.problem.ProblemReporter.handle(Unknown Source)
at com.spket.as.internal.compiler.problem.ProblemReporter.scannerError(Unknown Source)
at com.spket.as.internal.compiler.parser.Parser.parse(Unknown Source)
at com.spket.js.profile.ProfileParser.parseProgram(Unknown Source)
at com.spket.js.profile.JSVisitor.parse(Unknown Source)
at com.spket.js.profile.QXDVisitor.parse(Unknown Source)
at com.spket.js.profile.QXDVisitor.parseAll(Unknown Source)
at com.spket.js.profile.QXDVisitor.parseAll(Unknown Source)
at com.spket.js.profile.QXDVisitor.parseAll(Unknown Source)
at com.spket.js.profile.QXDVisitor.visit(Unknown Source)
at com.spket.js.profile.ProfileLoader.load(Unknown Source)
at com.spket.js.profile.ProfileLoader.load(Unknown Source)
at com.spket.js.profile.ProfileContext.loadClasses(Unknown Source)
at com.spket.js.model.Context$2.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)


Is there any workaround available?
Thanks
Marcel

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Mon Jun 22, 2009 6:18 pm

I have tried on Eclipse 3.5 RC4 and qooxdoo svn trunk version on Linux, and seems everything is fine. but the version number in file qooxdoo/version.txt is 0.8.2, I'm not sure that is the one you are using. have you tried the svn fix in this thread viewtopic.php?t=635

marcel
Posts: 2
Joined: Mon Jun 22, 2009 7:05 am

qooxdoo eclipse spket: unstable

Post by marcel » Thu Jun 25, 2009 1:41 pm

The patch helped a bit.
But during work eclipse got very unstable (e.g. suddenly Copy/Paste didn't work any more)
so I had to deactive skpet.

I'm using now the new eclipse 3.5 and I'm looking forward for the next spket release
which I will try again,

thanks
Marcel

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests