Content Assist fails on private Module functions - see

Get help with Spket IDE.
Post Reply
Bilsa
Posts: 5
Joined: Sun Jan 13, 2008 1:22 am

Content Assist fails on private Module functions - see

Post by Bilsa » Sun Jan 13, 2008 1:16 pm

Hi!, if I add a method as public, then the content assist works fine. If I make it private... then it fails. This seems to apply to the module pattern as shown:

Code: Select all

MyModule = function() {
	
	/**
	 * 
	 * @param {String} data
	 */
	var privateFunc= function(data) {	
		//This fails:
		data.
	};
	
	return {

		/**
		* 
		* @param {String} data
		*/
		publicFunc : function() {
			//This works:
			data.
		}
	};
}();
Is this a bug? Thank you!

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Sun Jan 13, 2008 3:11 pm

Hmm, this works on my computer, which version are you using, are you using standalone or plugin one?

Bilsa
Posts: 5
Joined: Sun Jan 13, 2008 1:22 am

Post by Bilsa » Sun Jan 13, 2008 7:25 pm

How strange...

I'm using version 1.65 eclipse plugin with eclipse 3.4.

Which version are you using?

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Mon Jan 14, 2008 2:09 am

Hmm, you are right, the private one treat "data" as Object, not the type in Comment which is String, it should be a bug

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Mon Jan 21, 2008 1:38 am

This bug has be fixed in version 1.6.6, thanks

Bilsa
Posts: 5
Joined: Sun Jan 13, 2008 1:22 am

Post by Bilsa » Fri Feb 01, 2008 10:50 pm

Cool, no, thank you :)

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests