Page 1 of 1

JSB file for ExtJS 5 on Eclipse

Posted: Wed Mar 11, 2015 3:23 pm
by LeDuc08
Hello,

I'm new to use spket module on eclipse.
I have make the installation of spket as eclipse feature without issue from here : https://github.com/DIRACGrid/WebAppDIRA ... ping-ExtJs

But, we have to select a jsb* file to activate correctly the completion of ExtJS methodes.
I try the JSB file present on the home tab of Spket portail, so I get some completion, but not all (like Ext.define).

I find a lot of suggestion for ExtJS 4 but not for 5, so could you please tell me which file I have to select from Ext-5.1.0 folder when I set the "javascript Profiles" ?

Thank you in advance for your help.

LeDuc

Re: JSB file for ExtJS 5 on Eclipse

Posted: Wed Mar 11, 2015 6:55 pm
by eric_suen
Yes, even with correct setting, you will miss lots of function, after all Ext 5 changed a lot.

Re: JSB file for ExtJS 5 on Eclipse

Posted: Thu Mar 12, 2015 7:48 am
by LeDuc08
Thank you for your reply,

So, If I well understand, for the moment we can not have all function of ExtJS 5 with spket.
Could we hope an improvement ? In which time ?

Have a nice day.

Re: JSB file for ExtJS 5 on Eclipse

Posted: Tue Jun 02, 2015 9:42 am
by kamleshs752
Hiii,
i have installed spket plugin and sencha complete i.e. 5.0.1 . and i followed this link https://github.com/DIRACGrid/WebAppDIRA ... ping-ExtJs
but , in my Extjs complete nowhere i find .jsb3 file .
can anyone suggest a solution
Thanks

Re: JSB file for ExtJS 5 on Eclipse

Posted: Wed Aug 31, 2016 5:56 am
by Meural
LeDuc08 wrote:Thank you for your reply,

So, If I well understand, for the moment we recommend phen375 can not have all function of ExtJS 5 with spket.
Could we hope an improvement ? In which time ?

Have a nice day.


So ExtJS 5 is not compatible with Spket but ExtJS 4 is?

Re: JSB file for ExtJS 5 on Eclipse

Posted: Thu Sep 01, 2016 3:29 am
by eric_suen
Spket supports Ext 4/5/6, what you need is jsb file for Ext which can be found in viewtopic.php?f=3&t=3692