the content assistent work incorrect

Get help with Spket IDE.
Post Reply
flywxly
Posts: 14
Joined: Sat Jan 26, 2008 3:48 am

the content assistent work incorrect

Post by flywxly » Fri Aug 29, 2008 11:41 am

The content assistent can't work when many 'Ext.applay' in a file!
The spket version is 1.6.15.
Thank you very much.

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Fri Aug 29, 2008 4:05 pm

Would you mind provide a test case? have you tried version 1.6.15.1?

flywxly
Posts: 14
Joined: Sat Jan 26, 2008 3:48 am

There is my code, thanks!

Post by flywxly » Tue Sep 02, 2008 5:45 am

The content assistent work incorrect when i include the other js files and used the Ext.apply.
My spket version is 1.6.15.1
example the red code:

//@include "/netmis/common/js/include.js"


KSS.grid.ColumnModel = function(config) {
Ext.apply(this, config);
return this.create();
};

Ext.apply(KSS.grid.ColumnModel.prototype, {
isEdit : false,
fields : [],

m_aryColEditer : [],
m_aryColName : [],

jsColTitle : {},

create : function() {
var newFields = [];

var checkboxIndex = 0;

this.jsColTitle
}
});

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Tue Sep 02, 2008 6:51 am

This example works for me, but since I don't have that include file, maybe that include tag affect the code assist, I create a quick fix, you can download:

http://www.agpad.com/downloads/com.spke ... 6.15.1.jar

and try again.

sergey_che
Posts: 14
Joined: Tue Mar 11, 2008 10:04 am

Post by sergey_che » Tue Sep 02, 2008 7:32 am

I had pretty much the same problem with included files.

The funniest thing that the same included file works fine in other, more complicated, project. But when I started a new one, included file and wrote @type tag for one and only variable, the content assist was broken.

Looks like problem is gone with the patched file.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests