eclipse 3.4 freezes using 1.6.15.1 or 1.6.15.2

Get help with Spket IDE.
shuo2002
Posts: 3
Joined: Tue Sep 16, 2008 4:34 pm

eclipse 3.4 freezes using 1.6.15.1 or 1.6.15.2

Post by shuo2002 » Tue Sep 16, 2008 4:44 pm

It only happens on eclipse 3.4, not 3.3. 3.4 freezes using either 1.6.15.1 or 1.6.15.2 after about 1 hour. It bothers me so much after upgrading to 3.4. I have to go back to 3.3. It seems that 1.6.15.x somehow has issues on eclipse 3.4 because freezing only happens when Spket editor is open. Everything is fine on 3.3. Does anyone encounter the same problem?

By the way, Spket is a GREAT editor. Keep going!!!

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Wed Sep 17, 2008 12:25 am

Is there any error in file workspace\.metadata\.log?

shuo2002
Posts: 3
Joined: Tue Sep 16, 2008 4:34 pm

Post by shuo2002 » Wed Sep 17, 2008 11:25 pm

No, nothing in the log file. I also tried 3.4 classic(sdk) build instead of JEE build. The same thing happended again. :(

sergey_che
Posts: 14
Joined: Tue Mar 11, 2008 10:04 am

Post by sergey_che » Thu Sep 18, 2008 9:52 pm

I had the same problem. But when I turned off General > Workspace > Refresh automatically, everything works fine (at least there were no freezes for a few days).

shuo2002
Posts: 3
Joined: Tue Sep 16, 2008 4:34 pm

Post by shuo2002 » Mon Sep 22, 2008 7:47 pm

sergey_che wrote:I had the same problem. But when I turned off General > Workspace > Refresh automatically, everything works fine (at least there were no freezes for a few days).
"General > Workspace > Refresh automatically" by default is turned off on my eclipse 3.4. I think "off" is the default value since I never change it.

pennywise
Posts: 22
Joined: Thu Sep 11, 2008 2:18 pm

Post by pennywise » Thu Nov 27, 2008 7:10 pm

Code: Select all

Eclipse M20080911-1700 (Eclipse Classic 3.4.1 win32)

Spket IDE 1.6.16
Xerces for Spket IDE 2.8.0

Subclipse 1.4.6
Subversion Client Adapter 1.5.2
Subversion Native Library Adapter (JavaHL) 1.5.4
Subversion Revison Graph 1.0.0
This is what I have installed. All from its particular eclipse update site. It freezes sometimes after 1min, sometimes after a whole day.

As shuo2002 says, "refresh automatically" is deactived by default. It's pretty annoying that freezing ...

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Fri Nov 28, 2008 7:46 am

What is your JavaScript Profile? a custom one or the default one provided by IDE? The JavaScript Profile is setting by "Window -> Preferences...", in category "Spket -> JavaScript Profiles"

pennywise
Posts: 22
Joined: Thu Sep 11, 2008 2:18 pm

Post by pennywise » Fri Nov 28, 2008 10:40 am

Didn't change anything and "Firefox 2.0" is the default one.

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Fri Nov 28, 2008 12:41 pm

That maybe cause the problem, when you said freezes, is it just freezes or will it open a stack overflow error dialog?

pennywise
Posts: 22
Joined: Thu Sep 11, 2008 2:18 pm

Post by pennywise » Fri Nov 28, 2008 12:43 pm

just freezes. no feedback at all. have to kill eclipse via the windows task manager.

pennywise
Posts: 22
Joined: Thu Sep 11, 2008 2:18 pm

Post by pennywise » Fri Nov 28, 2008 1:11 pm

now it just freezed again. here a picture how the freeze looks (yes, useless for debugging :) ). note the "white" menu-bar:

http://img262.imageshack.us/my.php?imag ... ezebz1.jpg

mouse cursor turns into a nice "hour glass" when hovering over eclipse. Last thing I did was:

Entering a "/*" into the sourcefile. pressing "Enter" for auto-completion of that comment block. then it freezed

eric_suen
Site Admin
Posts: 678
Joined: Wed Sep 28, 2005 7:00 am
Contact:

Post by eric_suen » Fri Nov 28, 2008 1:57 pm

Hi, can this bug be reproduced for same file by same action?

pennywise
Posts: 22
Joined: Thu Sep 11, 2008 2:18 pm

Post by pennywise » Fri Nov 28, 2008 2:05 pm

No I can't. I can't find any action that triggers the freeze, it just "happens"

pennywise
Posts: 22
Joined: Thu Sep 11, 2008 2:18 pm

Post by pennywise » Fri Nov 28, 2008 2:59 pm

now the "trigger" was:

Saving the File via CTRL+S
After typing "var A" Eclipse freezed.

pennywise
Posts: 22
Joined: Thu Sep 11, 2008 2:18 pm

Post by pennywise » Fri Nov 28, 2008 3:09 pm

and now the "trigger" was doubleclicking on a XUL-File in the Project-Explorer after switching between the open files...

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests