Page 1 of 1

Code completion not working with jQuery

Posted: Thu Apr 15, 2010 6:05 pm
by lukasz
Hi,

I have installed standalone version of SpekIDE and added jQuery library as described in tutorial.
Each time I start SpketIDE or open first Spket JavaScript editor I get an error.
SpketIDE 1.6.18, jQuery 1.4.2, Win 7 64 Bit, Java 6u20 32 Bit
!SESSION 2010-04-15 19:50:16.383 -----------------------------------------------
eclipse.buildId=I20070625-1500
java.version=1.6.0_20
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Framework arguments: -smid spket_100415194025647
Command-line arguments: -os win32 -ws win32 -arch x86 -smid spket_100415194025647

!ENTRY org.eclipse.core.jobs 4 2 2010-04-15 19:50:24.368
!MESSAGE An internal error occurred during: "Loading Context".
!STACK 0
java.lang.NullPointerException
at com.spket.js.profile.JQueryVisitor.visit(Unknown Source)
at com.spket.as.internal.compiler.ast.InvokeExpression.traverse(Unknown Source)
at com.spket.js.profile.JSVisitor.visit(Unknown Source)
at com.spket.as.internal.compiler.ast.ExpressionStatement.traverse(Unknown Source)
at com.spket.js.profile.JSVisitor.visit(Unknown Source)
at com.spket.js.profile.JQueryVisitor.visit(Unknown Source)
at com.spket.as.internal.compiler.ast.InvokeExpression.traverse(Unknown Source)
at com.spket.js.profile.JSVisitor.visit(Unknown Source)
at com.spket.as.internal.compiler.ast.ExpressionStatement.traverse(Unknown Source)
at com.spket.as.internal.compiler.ast.CompilationUnitDeclaration.traverse(Unknown Source)
at com.spket.js.profile.JSVisitor.parse(Unknown Source)
at com.spket.js.profile.JSVisitor.visit(Unknown Source)
at com.spket.js.profile.ProfileLoader.load(Unknown Source)
at com.spket.js.profile.ProfileLoader.load(Unknown Source)
at com.spket.js.profile.ProfileContext.loadClasses(Unknown Source)
at com.spket.js.model.Context$2.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Thanks,
Lukasz

Re: Code completion not working with jQuery

Posted: Fri Apr 16, 2010 1:39 am
by eric_suen
Take a look this thread viewtopic.php?f=7&t=1380 ,seems the same issue.

[SOLVED] Code completion not working with jQuery

Posted: Fri Apr 16, 2010 11:25 am
by lukasz
Thanks, that's working. I saw that thread but I thought I've already 1.6.18 version.